Issue playing on BWCSL servers

5

[5SI]Wraith

Guest
Hi All, just wondering if anyone else has this issue as is bleeding frustrating.

Whenever I join the BWCSL servers my top row of keys are disabled (ie u can press them but nothing happens - don't even register in console so cannot rebind or anything). Also other keys are seemingly randomly swapped - caps lock/tab become my L key and H seems to work intermittently.

At first I thought it was WWCL but my cs works fine on the MING-UK warserver and some other WWCL servers (then problem returns on BWCSL servers).

I have tried everything from a complete reinstall of CS and ran it as default, let BWCSL server create a config for me, partially added everything back in a step at a time (autoexec, config, etc) and still get same problem every time I join the server.

I can leave the BWCSL server, join another and my CS is fine, return to the BWCSL server and problem returns.

I played last week by rebinding all my slots to the number pad - this is when I discovered that some of my keys change midgame (main keyboard - number pad seemed to remain ok). As it stands this makes BWCSL pretty much unplayable for me - I certainly don't enjoy CS where I have to think what key do I need to press next allthe time.
With other servers being fine as well as WWCL this must be an issue with BWCSL servers or something they are running (could the website logon be causing anything like this?).

I run a basic machine set up - nothing fancy - p3 750, gf2 gphx card, soundblaster live soundcard, standard keyboard, intellimouse explorer, cable modem through network card, windows 98, but if it was hardware/OS related I would expect the issue to occur on other servers.

If anyone has experienced similar problems or knows how to correct it help would be appreciated as BWCSL is an excellent league and not being able to play it is a bit of a downer to say the least.

Here's clutching at straws :(
 
A

andersschm

Guest
I have enquired with the relevant parties on your behalf. This is the first I have heard of such an issue and unfortunately do not know enough about the server setup to answer for you myself.

The barrysword logon should not affect it though - that gives your IP access through a firewall so you can see the servers as far and as far as I am aware should not interfere with CS.

WWCL should not reassign key allocations though. Are you using any form of external application while playing CS like voice comms or other package? Do you use custom scripts?

Anybody else have any experience with problems of this nature?
 
T

[TNN]Aardvark

Guest
Are your actual keys being swapped, or just the binds?
 
A

andersschm

Guest
The server admins came up blank I am afraid - they said they have heard of this on some Jolt servers running WWCL. Have you tried any WWCL or CS specific forums for help?
 
5

[5SI]Wraith

Guest
I've literally tried everything from default config after reinstall, then adding my autoexec and configs and the standard low fps models 1 step at a time - get the problem with any set up so was baffled as to what was causing it.
I use standard scripts in autoexec - usual buy binds and slot 1/2 bound to mwheel up/down, a name change script, sayreload script and a showscores + netgraph + timeleft script.

It appears to actually disable the top row of keys (1-0, -,=,backspace, etc) so that they don't register at all when u press them - even in console (I tried to just rebind them - no joy as no key registered to bind something to).
Escape had me permanently running forward for some reason, caps lock seemed to act as my say bind to L (sorry for spamming the Laserlips yer momma was a snowblower a couple of times that match). H wasn't rebound but functioned as if something was stuck under it (ie intermittently) and a few other letters on the main keyboard either didn't work or occasionally decided to act as another letter - w,a,s,d were not affected (which was weird but lucky) but most of my other keys were.

I did manage to duplicate the effects on a non bwcsl server but that was after they had happened on bwcsl server (thanks for letting me test after hours btw admins although it hasn't helped it was appreciated) and this was only once (on ming server). When I join a non bwcsl server with wwcl my keys are fine (ming server again) - this after a reinstall but fine since, and when the issue occurs on BWCSL I can join another server immediately and be fine. I had thought it might be my keyboard or windows flipping out but is standard us english keyboard - no settings changed in windows or anything and like I say it works fine immediately on joining a different server.

The only bright spot is that my keypad is unaffected (or seemed ok in the one full match I played cos we were short) but this means I take longer to reach grens and stuff instead of the usual non-thought requiring setup I have. I could cope with that (well am crap anyways lol so no one would notice ;o) ) if it didn't reassign keys/binds midgame. This doesn't happen all the time - it seemed to be about 6-10 swaps during the course of the game (not a lot but was usually inconvenient - such as my buy key or reload) - the mid game ones seemed to be only bound keys (apart from the intermittent H) so I would guess this is reassigning binds rather than swapping keys (but am not majorly technical).
If I can get hold of another keyboard I'll try to test it after hours again to eliminate the possibility that it's my 2 year old keyboard (but would have expected issues on every server then) - other than that I am at a complete loss as there is apparently only one version of wwcl so can't be different versions on the BWCSL and ming servers (which I had thought might be the case).

I haven't managed to track down a technical forum for wwcl as no one seems to know a url (one would be handy if u have it :eek:) )so not requested help there.

While u may not be able to help I do appreciate the time you've spent checking this out - just a pity I'm missing the damn fine league (althought the lads deserve a break from me flashbanging them all :/ ).

Thanks again and I'll keep trying - if I manage to ID the problme I'll post here for reference.
 
A

andersschm

Guest
[bsq]Marcwayne came to play for us on Wednesday, his first time in BWCSL this season. He had to quit from the server experiencing similar problems as yourself.

I will ask him to come along and post some information about his setup so perhaps we can see if there are similarities to what is going on.

If you know of anyone else having problems then get them to post here and I will take the information back to the server admins when we have more.
 
5

[5SI]Wraith

Guest
Asked around - only thing I can find is people with their mouse sensitivity being altered by wwcl - they couldn't trace the problem either - nothing similar to my keyboard issues (apart from your guy).

Did Marcwayne have an anti virus program running at all? I have norton antivirus but it is set to only check incoming files not run constantly.
 
E

ECA

Guest
One of our new trialists had this problem.
He joined a server and all his keys were unbound.
He said he fixed it via changing his brightness, but he had installed someone elses config.

So try using the cplgui to create a config for you :-]
 
D

Dr_Weasel

Guest
I too have most of my config rewritten everytime I join a BWCSL server. It doesnt happen on any other wwcl server either.

The most annoying change is that it re-binds my reload from Mouse4 to right shift.... The other thing is that if I have num-lock switched on, my gun auto reloads after every shot. This only seems to ever happen on BWCSL...

Im not sure what its upto, but it seems to resourcing some file in from somewhere as my name always changes to =|MawR|=Dr_Weasel after the WWCL config check has been run no matter what it was set to to start with. Ive yet to track down where it is getting this info from though...

The way I have gotten around this for the mean time is to setup your config as normal, leave CS and then take a copy of you config.cfg file in the cstrike directory. Save this as keys.cfg or something. Edit this new file and remove any line that doesnt begin with "bind=".

Once wwcl knackers up your config again (everytime it is run after map change), go to the console ("~") and then type "exec keys.cfg". This will reset all your binds back to how you like them.

Pain in the ass, but at least I can reload in the heat of the moment.
 
R

RtG

Guest
just do exec config.cfg (or any other configs you may use) after wwcl has finished doing its thing and it'll reset any binds that have been lost.
 
M

Moff^

Guest
bind's problem

After quickly scanning the post's above, could you not just make your config's read only & bind a key to exec copyofconfig.cfg??
 
D

Dr_Weasel

Guest
Mine is write protected. It doesnt seem to make permenant changes to your config, only whilst you are playing on that server.

And the troule with binding a key to exec copyofconfig.cfg is that wwcl deletes most of the binds so chances are the bind wont work after its done its mangling job anyway....

Nice thoughts though :)

WWCL is still a pain in the ass though....
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Similar threads

C
Replies
4
Views
653
Dr_Vegas
D
O
Replies
13
Views
502
[TNN]Aardvark
T
O
Replies
5
Views
305
G
W
Replies
9
Views
538
andersschm
A
S
Replies
1
Views
368
C
Top Bottom