This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windows 98 Keyboard Language

Discussion in 'Techie Discussion' started by ]SK[, Jan 12, 2004.

  1. ]SK[

    ]SK[ One of Freddy's beloved

    Ive got a custom whos laptop insists that he use English (United States). If you try to change it to anything else or even make a change then click apply the machine makes a ping noise as if it were trying to popup an error. Close and reopen keyboard properties and its back to the US again. Ive googled and all sorts, remove keyboard drivers and reinstall but cant fix it, ideas?
     
  2. Shovel

    Shovel Can't get enough of FH

    It's because you can't remove the default keyboard map that's currently in use, only add additional ones.

    Win 98 may be slightly different from XP, but I seem to remember that the dialogs are the same, so do this:

    1) Add the English (British) layout and see if you can set this as default. What you may find is it will let you remove the US layout, but it wont let you Apply it. So,
    2) Don't remove English (US) yet, but hit apply and check that you can use the UK layout. (You may want to check the "Language" taskbar for dynamically switching between if it hasn't chosen British for you by this point. That is accessible from right clicking on the Taskbar, choosing "Toolbars" and "Language Toolbar". It's the same place that you'd find Quick Launch.
    3) If it now lets you type in British and still want to remove the US layout, reboot the machine and then return to the Keyboard layout properties and remove the US layout. With British now set to default, you should find that it's problem free.

    Hope that helps ;)
     
  3. Jonty

    Jonty Fledgling Freddie

    Hi ]SK[

    Where have you tried to change the language from? The 'Regional and Language Options' (if it is called that in Windows 98) in the Control Panel contains pretty much all the language options. Alternatively, have you tried altering the language in programs like Word just to see if it works (Tools > Language > Set Language)?

    Not much help, I know :(

    Kind Regards
     
    • Like Like x 1
  4. ]SK[

    ]SK[ One of Freddy's beloved

    Nope cant add, I add one so it appears in the box. Click apply or ok and both times it beeps. Reopen the keyboard properties and its back to US on its own again.

    I just noticed the Language shotcut thing is in the task bar, I thought that was only availble if you had more than one language installed. It currently only has one!

    Ive also tried changing this in safe mode. Same thing.
     
  5. ]SK[

    ]SK[ One of Freddy's beloved


    Nope doesnt work. Those settings are really for the dictionary. Its as if the file what ever the leyboard properties edits is read only or at least something wont let it change. Which is why ive tried in safe mode.
     
  6. ]SK[

    ]SK[ One of Freddy's beloved

    Actually ANYTHING in the Keyboard properties doesnt work. You can change things but they dont get applyed. It just fecking beeps. Argh this is annoying. Tried System File Checker for any corrupt files and found three that wernt of any relevance.
    Actually the others work after a reboot. If you try to change the language then do the others they fail until the next reboot.
     
  7. ]SK[

    ]SK[ One of Freddy's beloved

    Well to let you know I got there in the end. I had to add a reg hex code to tell windows that British is now its default setting. Still wont let you change settings in the Keyboard Properties at least its letting him do the old £ instead of a #.
     
    • Like Like x 1

Share This Page